Multiswitches défectueux (merci Fracarro)

Pour exposer ou enrichir ses connaissances techniques sur le sujet...

Re: Multiswitches défectueux (merci Fracarro)

Messagepar Marc2 » 12 Avr 2019 17:49

Voilà une photo prise en cours de réparation. Les couleurs sont plus réalistes.

T3 a été dessoudé. Sous la patte du collecteur, le FR4 a tellement chauffé que l'époxy a disparu, on voit le tissu de verre. On voit la trace d'une piste (celle qui polarise la base) sous le boîtier, qui est fendillé. Les pistes sont décollées, j'ai du éliminer celle de la base qui est remplacée par un bout de fil. La pastille du collecteur est restée sur le transistor.

Les résistances de collecteur sont déjà remplacées sur la photo (cette fois 3 fois 180 ohms parce que je n'avais plus de 150). J'ai aussi mis un coup de fer à souder malencontreux sur une inductance de 4,7 µH (jaune) mais ce n'est pas grave.

Bon, tout est réparé et ça marche. Mais je ne veux pas le remettre en service sans remplacer T2 qui a du souffrir. L'ennui est que le BFG541 est obsolète, alors je vais mettre un autre BFG591 (obsolète aussi, mais j'en ai) dont les caractéristiques sont assez proches. Sinon un BFU590G.

Image
Avatar de l’utilisateur
Marc2
Etalon
Etalon
 
Messages: 1816
Inscription: 29 Oct 2007 23:45

Re: Multiswitches défectueux (merci Fracarro)

Messagepar Marc2 » 15 Avr 2019 18:58

Voilà, j'ai changé T2, j'ai mis un BFG591 au lieu du BFG541. Ça marche parfaitement. Le BFG541 devait juste revenir moins cher.

Image
Avatar de l’utilisateur
Marc2
Etalon
Etalon
 
Messages: 1816
Inscription: 29 Oct 2007 23:45

Re: Multiswitches défectueux (merci Fracarro)

Messagepar Marc2 » 17 Avr 2019 18:57

Troisième multiswitch remis en service, et donc quatrième déposé pour analyse.
Le problème est évidemment le même, mais la conséquence est un peu différente : le transistor est mort en court-circuit, ce qui a fait cramer les deux résistances de collecteur et l'une des résistances d'émetteur.
Bon allez, passage sur le billard programmé demain :yes1: mais si mais si, tout va bien se passer.
Avatar de l’utilisateur
Marc2
Etalon
Etalon
 
Messages: 1816
Inscription: 29 Oct 2007 23:45

Re: Multiswitches défectueux (merci Fracarro)

Messagepar Marc2 » 19 Avr 2019 18:30

Et voici le quatrième et avant-dernier, après réparation. Ça ressemblait à Notre-Dame là-dedans, j'ai fait ce que j'ai pu. Certaines empreintes étaient fichues, j'ai préféré mettre une résistance à pattes (59 ohms).

Image

Et le dernier multiswitch, déposé et ouvert, présente encore et toujours la même panne que ses copains.
Avatar de l’utilisateur
Marc2
Etalon
Etalon
 
Messages: 1816
Inscription: 29 Oct 2007 23:45

Re: Multiswitches défectueux (merci Fracarro)

Messagepar toTOW » 20 Avr 2019 17:18

La couleur du PCB indique quand même qu'il prend cher ... :?
FAH-Addict, première source d'information francophone sur le projet Folding@Home .
toTOW
Maître des airs
Maître des airs
 
Messages: 911
Inscription: 08 Avr 2011 21:21
Localisation: Cestas

Re: Multiswitches défectueux (merci Fracarro)

Messagepar Marc2 » 21 Avr 2019 07:57

Même après correction des valeurs (et réparation), ça chauffe quand même un gros chouilla. Il aurait fallu éloigner T2 et T3. Quand on place les composants sur un PCB, on oublie souvent d'écarter les sources de chaleur, mais c'est plus facile à dire qu'à faire, surtout quand il y a de haute fréquence et que la disposition influe sur les performances.
Avatar de l’utilisateur
Marc2
Etalon
Etalon
 
Messages: 1816
Inscription: 29 Oct 2007 23:45

Re: Multiswitches défectueux (merci Fracarro)

Messagepar Marc2 » 25 Avr 2019 12:21

Et hop, dernier multiswitch réparé :nn:
Les dégâts n'étaient pas trop importants. J'ai mis un BFU590G à la place de T2, il faut bien écouler les fonds de tiroir et ça marche très bien.
Je vais pouvoir passer à un autre chapitre de la rénovation de l'installation.
Avatar de l’utilisateur
Marc2
Etalon
Etalon
 
Messages: 1816
Inscription: 29 Oct 2007 23:45

Re: Multiswitches défectueux (merci Fracarro)

Messagepar marceljack » 25 Avr 2019 12:51

Marc2 a écrit:Et hop, dernier multiswitch réparé :nn:
Les dégâts n'étaient pas trop importants. J'ai mis un BFU590G à la place de T2, il faut bien écouler les fonds de tiroir et ça marche très bien.
Je vais pouvoir passer à un autre chapitre de la rénovation de l'installation.
Félicitations pour cette réparation :!:
Pour augmenter la fiabilité, ne serait-il pas possible de diminuer les courants de fonctionnement des transistors pour réduire les échauffements :?:
Installation TNT: Paris: VTU50 collective 21-60 / Royan: Lambda 9 + préampli
TV HD: Thomson FE9234B, Philips 39PFL3807, Acer AT2356,
PC: Pinnacle PCTV310i & 310e, Technaxx DVB-S3, Techgear Diversity Stick, Terratec TStick+
marceljack
Brigades du Tigre
Brigades du Tigre
 
Messages: 20391
Inscription: 06 Oct 2005 17:59
Localisation: 75019 PARIS

Re: Multiswitches défectueux (merci Fracarro)

Messagepar Marc2 » 25 Avr 2019 14:32

La température de fonctionnement de T3 dépend de sa propre dissipation, et dans une moindre mesure de la puissance totale du multiswitch (qui conditionne la température dans le boîtier).

Avec les nouvelles valeurs de composants, les dissipations dans la voie hertzienne/câble sont (sous 12 V) :
  • T3 : 500 mW dans le transistor, 840 mW dans l'étage complet
  • T2 : un tout petit peu moins
  • T1 : 250 mW dans le transistor, 430 mW dans l'étage complet
  • l'ampli de la voie retour : pareil que T1
ce qui fait 2,5 W, et ces étages ont la malchance de se trouver en haut du boîtier (j'ai pensé les monter la tête en bas, mais ce n'est pas simple à cause des câbles).

Il faut ajouter :
  • les 8 amplis des BIS satellite : environ 2,7 W sous 12 V
  • la perte dans les régulateurs de tension qui abaissent l'alimentation 18 V en 12 V, à peu près 2,7 W
Au total un multiswitch dissipe 2,5 + 2,7 + 2,7 = 8 W :( (la consommation est de 440 mA).

La puissance de T2 et T3 ne pèse pas bien lourd dans le total. On pourrait économiser un chouilla en baissant l'alimentation (14 ou 15 V suffiraient).

T2, qui consomme et dissipe presque la même chose que T3, a survécu pendant 20 ans (j'en ai changé certains, c'était juste par précaution), donc je pense que maintenant T3 est promis à plus d'avenir que l'installation de l'immeuble elle-même (ou que ma présence dans l'immeuble).

PS : je ne compte pas la puissance des voies de sortie, qui sont alimentées par les récepteurs (en 13 ou 18 V selon polarisation).
Avatar de l’utilisateur
Marc2
Etalon
Etalon
 
Messages: 1816
Inscription: 29 Oct 2007 23:45